Can't control Metz Mecablitz 58 AF-1 with V6 IIs on a Sony A77II


My camera is a Sony A77II.
I have a Metz Mecablitz 58 AF-1 digital flash, and a 48 AF-1 is on the way.
To expand my photography, and to be able to use both flashes on location,
I bought the Cactus V6 IIs system.
Because it is plug and play, detects cameras and flashes, and can controls the zoom and intensity of the flashes.
Excited when they came (I have three of them, the third bought in advance for my second flash that I will get next week, the 48 AF-1), I got to setting them up.
I didn't see the Cactus auto-detecting like in the YouTube videos (where you see 'DET' in the display),
but the display read the S for Sony, so I thought it must be okay,
and that it skipped DET because it is a Sony dedicated Cactus.
My flash was on TTL, my camera is on Manual Mode.
I was able to take a picture and the flash went off. Great!
But I haven't been able to adjust the zoom on the flash, or its intensity.
It stays at full throttle, I can't bring the flash output down via the Cactus like it's supposed to.
And the ability to control my flash(es) was the reason why I bought the three Cactus units.
So right now I'm feeling quite disappointed.

Did I do something wrong in setting them up?
Is the Cactus V6IIs able to control the zoom and intensity of a Metz Mecablitz 58 AF-1 to begin with?

I hope you have some answers, because if I don't get this to work,
I will have to return the Cactusses,


  • Added comment:
    During testing my flash went into Slave mode on its own,
    and I wasn't able to get it out again while it was on the Cactus.
    It went on the remote setting too.
    So something IS happening, just not what is supposed to be happening.
    I'm convinced it must be some kind of setting that I don't have right,
    but I followed the right setting in my opinion.
    Flash on TTL.
  • The shifting to slave mode is solved.
    It had to do with my camera flash-setting being on remote.
    Changed that, but still no response when I try to control the flash via the Cactus.
  • I've replied your email. Please check.
    Ray Chan

    Senior Product Specialist
    Harvest One Limited
  • I have received my Metz 48 AF-1 for Sony,
    and it work fine with the Cactus, straight off the bat!
    So it's proven to me that my Cactus system works,
    and there must be something wrong with the 58 AF-1.
    Maybe a setting, maybe the flash itself is faulty.
    Does anybody have any ideas?
    Suggestions would be much appreciated, thx!
  • How are / were you connecting the Metz? The 58AF1 uses the old Minolta Dynax Autolok foot, so presumably you had it on the adapter foot. Had it clicked into place fully?

    I had a 58AF1 and would happily have checked this out for you. Unfortunately I dropped mine on a hard floor a while back and broke it. A shame really as it was a good flash.

    I hope you've got this sorted OK.
Sign In or Register to comment.