Firmware update failed

edited October 2017 in RF60X FAQ
On a Mac, trying to update flashes, I get the error message "Embedded file is corrupt or missing".  Any suggestions?

***Quickly resolved this myself.  Seems it didn't like that I had just updated a couple of V6ii's first.  By closing the program and rebooting it, it worked fine.


  • Thanks for posting an update, @fear4fun

    Please do not to hesitate to post if you require further assistance.
    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at  At Cactus, we listen. 
  • I am getting the same problem "Embedded file is corrupt or missing". I am running OS X Yosemite 10.10.5 Cactus Updater version 1.08. After attempting to upgrade, it says it is completed but I still get the message "Embedded file is corrupt or missing" when I connect to the RF60X. I want to use this flash with my Fuji X-Pro2.
    Please see attached images. 
Sign In or Register to comment.