TTL not working on Sony a77ll

Hi there
I just updated my two rf60 flashes V205 and my v6lls trigger v son.1.001
When I take a picture I am not getting ttl to work. I tried the ev -5.00 to + 5.00 and there is no diffidence in the light out put. I am not sure what could be the problem.
The flash does show that I am in ttl mode and the trigger does as well. 


  • Please can you tell us more about your camera settings.
    I have same gear and the TTL works.
  • iso 400 f5 80th sec.
    When I shot tonight to see if I could get it to work in Manuel mode the flash out put need to be at 1/8 power for a good picture. When I went to ttl all I got was a black picture. I tried to set a delay of 1ms and the flash never even fired. I am not sure if I just got a bad update or what.

  • I got it to work. I just had to uninstall the updater and reinstall it back on to my computer. Then I updated my two flashes and v6lls. I am hoping that Cactus comes out with a 600w strobe that has HHS that works with there v6ll triggers that would be great for out side to over power the sun.
  • Great. The ILCA-77M2 with the Cactus flashes is a great combination.
    Do not forget to turn off the Electronic Front Curtain if you are shooting over 1/1000 and HSS off-camera flashes.
Sign In or Register to comment.